Jump to content

Recommended Posts

On 6/12/2019 at 7:30 PM, movomo said:

I know what's happening, I know why it's erroring out. But I don't know why this did not happen to someone much earlier.

Try this one and tell me if the error messages were gone. Then I'll update it.

 

Damn! I guess you beat me to it. So you can't check now... but anyway, the new one should prevent the mod from not working even if autosetbody itself was disabled.

 

SetBody.espFetching info...

Yes, now it's working with default values. Thanks for help. 🙂

Share this post


Link to post

What is the folder with the bodies of this mod?

===============================

I want to make a mod that strips sleeping actors (well, already done). I need to exclude the SetBodi folder.

Share this post


Link to post

The meshes?  

The folder all SetBody mods use

data\meshes\characters\bombshell   and then many subfolders

Share this post


Link to post
45 minutes ago, fejeena said:

The meshes?  

The folder all SetBody mods use

data\meshes\characters\bombshell   and then many subfolders

yes thank you, meshes for GetBipedModelPath [sex] [ClothingRef] operator.

It doesn't matter which subdirectories there are, it gives the index number in the string from which the real name of the folder or model begins.

Share this post


Link to post

The non animated futa options are still missing penis texture, even in the latest release.

Share this post


Link to post
17 minutes ago, hockles said:

The non animated futa options are still missing penis texture, even in the latest release.

The No-LAPF meshes ? the meshes without penis bones?  (Ok the flaccid versions does not have penis bones )

 

The flaccid and erect version use the footfemale texture. So they have a texture  even if you have not install a HGEC textures replacer the game will use the vanilla foot textures.

flaccid and erect  mesh

Spoiler

futa.jpg

 

futa2.jpg

 

Yes they are uniform/monochrome skin color because the female texture does not have a penis textures part.  You can not change it. A body mesh is set to skin so it use the race textures that is set in the esp/esm  and the color of the penis change if you use the color sliders in the race menu. If you would add a pens texture and  change the NiMaterialProperty in the nif to "material or Penis or default"  the mesh will always use the penis texture but the texture color will fit only with one race ( If you use Imperial Penis color  the dark elves and orcs will look funny .  And even a imperial can look bad if his shin color  is set to light or dark, because the penis does not responds to the color slider )

You can add a penis part to all the female race textures and then change the penis UV map of all SetBody futa meshes to match the penis position on the texture.

 

You copy the penis from a male texture

Unbenannt.jpg

 

 

to the female texture and recolor it to fit the female color.

FootFemale1.jpg

 

 

Or you "draw" a new penis texture on the female texture. Because the UV map of the futa penis is not the same as the male penis.

The male UV map you see in the male texture above, the white grid part.

And the female penis UV map from SetBody reloaded looks like this ( the white part )

futa3.jpg

So you see what part of the female texture the SetBody mesh use, and normally there is only monochrome skin color.

So you can add the penis texture at that position and must not change the UV map in the meshes.

( The above texture is my Imperial texture, I add the penis at the bottom, a the pink texture part between the legs is for pussy lips and the dark part on the right is for horse and dog penis )

 

Share this post


Link to post
1 hour ago, fejeena said:

The No-LAPF meshes ? the meshes without penis bones?  (Ok the flaccid versions does not have penis bones )

 

The flaccid and erect version use the footfemale texture. So they have a texture  even if you have not install a HGEC textures replacer the game will use the vanilla foot textures.

flaccid and erect  mesh

  Reveal hidden contents

futa.jpg

 

futa2.jpg

 

Yes they are uniform/monochrome skin color because the female texture does not have a penis textures part.  You can not change it. A body mesh is set to skin so it use the race textures that is set in the esp/esm  and the color of the penis change if you use the color sliders in the race menu. If you would add a pens texture and  change the NiMaterialProperty in the nif to "material or Penis or default"  the mesh will always use the penis texture but the texture color will fit only with one race ( If you use Imperial Penis color  the dark elves and orcs will look funny .  And even a imperial can look bad if his shin color  is set to light or dark, because the penis does not responds to the color slider )

You can add a penis part to all the female race textures and then change the penis UV map of all SetBody futa meshes to match the penis position on the texture.

 

You copy the penis from a male texture

Unbenannt.jpg

 

 

to the female texture and recolor it to fit the female color.

FootFemale1.jpg

 

 

Or you "draw" a new penis texture on the female texture. Because the UV map of the futa penis is not the same as the male penis.

The male UV map you see in the male texture above, the white grid part.

And the female penis UV map from SetBody reloaded looks like this ( the white part )

futa3.jpg

So you see what part of the female texture the SetBody mesh use, and normally there is only monochrome skin color.

So you can add the penis texture at that position and must not change the UV map in the meshes.

( The above texture is my Imperial texture, I add the penis at the bottom, a the pink texture part between the legs is for pussy lips and the dark part on the right is for horse and dog penis )

 

Correct, the ones without bones.
No it's missing as in.. the penis is Grey. No texture on it at all. The Flaccid and Erect versions both have Grey textures.

Share this post


Link to post

Do you have a HGEC texture with gey texture above the body ?  Open your texture and check it.

A missing texture would be purple in game.

 

There are texture that do not have the body color where no body is

Like this

tex.jpg

 

Would be look very bad with the SetBody futa meshes.

Share this post


Link to post

The 4shared link doesn't seem to work for me. Does anyone have a copy of the mod they'd care to link? I'm using the femboy mod and would like to make myself the only femboy in Cyrodiil.

Thanks in advance

Share this post


Link to post
On 9/9/2019 at 4:27 PM, fejeena said:

The links in post 829 are all fine, just tested it.

ah, didn't know they where their. thanks. also, what way do I get SetRace to work with custom Races?

Share this post


Link to post
On 6/11/2019 at 10:30 PM, movomo said:

I know what's happening, I know why it's erroring out. But I don't know why this did not happen to someone much earlier.

Try this one and tell me if the error messages were gone. Then I'll update it.

 

Damn! I guess you beat me to it. So you can't check now... but anyway, the new one should prevent the mod from not working even if autosetbody itself was disabled.

 

SetBody.esp 526.87 kB · 20 downloads

Quite a necro so to say? But I spent 2 days trying to just find the issue I had and here it was perfectly described and the .esp plugin that works added. The issue is resolved, the body changes stay after I close and restart the game. This plugin has fixed the issue.

Share this post


Link to post

Hi, i have some problems with this mod. I've downloaded it from nexus and enabled BombshellQuest.bEnableAutoSetBody in setboxy.ini. Now game just freeze in loading state upon starting new game. What causes it?  I have oblivion reloaded and OCO installed (and that's all)

Share this post


Link to post
46 minutes ago, DMC500 said:

Hi, i have some problems with this mod. I've downloaded it from nexus and enabled BombshellQuest.bEnableAutoSetBody in setboxy.ini. Now game just freeze in loading state upon starting new game. What causes it?  I have oblivion reloaded and OCO installed (and that's all)

 

There are numerous versions of SB...try the one from here.

Share this post


Link to post
18 minutes ago, DogOnPorch said:

 

There are numerous versions of SB...try the one from here.

oh, nevermind. it's just my SSD's cable got slightly disconnected and ruined my game installation.

Share this post


Link to post

I tried installing this mod after coming back to Oblivion after a decade.  I installed it, the script extender, the hi-rez texture and Coronerras skeleton.  After changing the character's body I get that error where the tits extend out to infinity.  I just want a PC unique body.  Is there something I'm missing or overlooking?

Edit: Ah, never mind.  I was having trouble with the archive invalidation.

Share this post


Link to post

Hi all, I have installed all, Core, data and patches for LAPF, but I was wondering how autoset body works? Is it working in the lastest zip?

Because I can change bodies but I havent seen what autoset body does...

 

I installed all with Nexus mod manager.

And also was wondering if I need to install Roberts replacer and female HGEC, or does it works without them? (and if it works without them, does LAPF works? if I have autoset)

Share this post


Link to post

Nexus mod manager  and Oblivion ?  NEVER ! ! !  especially  no LoversMods.

Lovers will not work right !

 

SetBody only have  body meshes, no textures. So you have to install Roberts male and HGEC female to get the textures.

 

 

Read my Link   https://www.loverslab.com/topic/36443-oblivion-install-gametoolsbodiesbbb-load-order-sorting-espesm-cleaning-cs-cse-body-stretching/All you need before you imstall Lovers. Nude bodies, armor-clothes replacer, BBB animation, tools,...

 

If you have your game in C : / program files it will not work

If you have installed Lovers Mods with Nexus/Vortex Modmanager Lovers will not work

....

Read  it from the beginning !!!

 

-------------------------------

 

Once there was a AutoSetBody esp  but now it is only a ini. ( If you have a old esp, delete it )

In the SetBody ini you enable AutoSetBody

 

And in the AutoSetBody ini you  can change settings.

 

Share this post


Link to post

Thanks for replying, apart from autobody set, and some crash from slaving bandit npcs, I havent had trouble with NMM. But you know your stuff so Ill try again Oblivion Mod Manager.

So autobody set "should" do as it says in desc, and give every npc different body right? 

 

No I dont have it in C:, its under steam but in other "drive". I have installed roberts male and HGEC for LAPF.

Share this post


Link to post

Yes AUtoSetBody give every npc different body ....   but you onlyhave one armor-clothes replacer.

 

If your armor clothes replacer for female is HGEC E cup  you will see all female NPC in game with E cup armor and clothes.  Only nude, during sex, you will see the different nude bodies add by AutoSetBody.

So It can be you see a clothed E cup girl and during Sex she has A cup  or  J cup tits.

 

I don't use it.

But if I remember right there are Mods that can add the right clothes to the NPCs. But you have to install for every body you use a armor-clothes replacer.  And you have read my Link, so you know there are not many armor-clothes replacer.    But in the AutoSetBody ini you can set which bodies should be used.

The "add clothes Mod" checks the SetBody Body and add the right clothes  ( You have to set it in a ini )

 

As I said I  do not use  it.

My NPCs all use E cup body and  I have a E cup armor-clothes replacer.

Some Mod NPCs I have changed.  I added nude bodies ( no E cup ) with Blockhead  and put matching armor/clothes in the NPC inventory ( also part of the Mod )

And My female Player use a H cup body ( add with Blockhead)  and only use Mod H cup armor/clother .

 

So Player and all NPC have matching nude body and armor/clothes.

 

Share this post


Link to post

Hello,

 

I'm having an issue with auto set body. (I'm gonna go on a limb here and guess it has to do with Mo2's virtual machine functions)

I don't know why I'm having this issue since I'm competent enough to have had all of my mods work correctly in my last install. The setbody reloaded blockhead edition autosetbody option isn't working despite having the option for autosetbody to run being on in the setbody and autosetbody ini files.

 

I just remembered this, when I tried activating set body on a nude female npc, I wasn't able to change her body.

 

I'm using the mesh extended swap system full package found on Lovers Lab. I know that setbodymess chooses armor based on body type. Female npcs will be wearing dmra armor but have the default female nude suit on when animations start, stripped of their armor, or when killed and have their armor taken. The same thing applies to those wearing dmra clothes from the clothing addon from the same package. I even have the appropriate break armor plugin and ini, the one that's part of the mesh extended swap system, functioning correctly. I saw the arena armor meshes swap out to degrading versions of themselves while I was fighting an opponent in the arena. When I launch the game and check the console, it tells me something along the lines of that 72 actors are in charge of setbody, the same message I got in my last install when autosetbody and setbody were working correctly.

 

I know that the plugins are working because I'm not even having trouble with oco v2, which means blockhead is working.

 

To get a dot bat file running correctly for one of the mods found on these forms, I even ran taskmanager through Mo2 and ran the bat file with administrator privileges.

 

I don't know why I'm having set body not swapping out nude meshes except the fact that the major thing I did differently compared to my last install is that I'm using Mo2 as a base and made sure to have Oblivion force load the obse library so obse and it's plugins work. To keep it extra clean, I basically surgically remove mod files installed into the base Oblivion folder by obmm into their own folders inside mod organizer 2. The main one that I'm forced to keep inside is DarnUI so it functions correctly. I also have the high heel system and giving npcs their own walk animations installed inside the root directory form the obmm install because, I wanted to save the headache of combing through my data folder for the related files. Both mods function like all the other mods. The only mod that doesn't work right is setbody.

 

The only modifications I added to the set body mod is that I installed an expanded setbody menu, which didn't change the esp, by copy and pasting some text to the set body menu. Before then, however, it wasn't even working because female characters still had the default nude suit on and me changing the ini file didn't break my game last time.

I'm willing to check again, with the base setbody ini however.

 

In my last install, I used Obmm and Wyrebash solely, if it comes to having to move all of the files into the root folder, I'm fine with it. But, I'm gonna fight to have this work. 

 

The only thing I'm not sure of is that if there's a lovers lab version of set body. I doubt it bc I could've sworn I saw movomo's name in the read me from the version I got off of nexus mods.

 

Anyone have suggestions or advice? Reinstalling things isn't gonna be much of a pain for me if I gotta do that too.

 

Any suggestions or recommendations made to assist will be appreciated.

 

Edit: corrected self on setbodymess dot esp function.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...