Jump to content

Recommended Posts

Script Mod Import Error (sims4communitylib.dialogs.option_dialogs)

Broken/Outdated mod is importing the 'sims4communitylib.dialogs.option_dialogs' module.

A broken or outdated modification is attempting to import the 'sims4communitylib.dialogs.option_dialogs' module and fails. The mod is too new, the game is too old, or the required mod is missing.

You need to locate the TS4SCRIPT file, in your The Sims 4 Mods folder, that could be causing this issue and remove it.
If this is a new issue, try removing the most recent mod you have installed.

Sims4CommunityLib_Exceptions.txt

Share this post


Link to post
1 hour ago, sasoridei said:

Script Mod Import Error (sims4communitylib.dialogs.option_dialogs)

Did you read the red text above your comment?

Share this post


Link to post

Hi,

 

No matter how much friendship my sim and pet have. Every started action makes my pet or sim angry. They refuse sex. Even with all cheats on. (Alwas accept, zoo trait, having met, 100% friendship, they are companions... ) Same thing with another dog I tried...

 

ww150a

S4CL 1.2.6

WP 7.0.16 beta

 

Maybe I missed something...

Share this post


Link to post
2 hours ago, Zemacz said:

Hi,

 

No matter how much friendship my sim and pet have. Every started action makes my pet or sim angry. They refuse sex. Even with all cheats on. (Alwas accept, zoo trait, having met, 100% friendship, they are companions... ) Same thing with another dog I tried...

 

ww150a

S4CL 1.2.6

WP 7.0.16 beta

 

Maybe I missed something...

That sounds like something I've been hearing about with normal sex in the WW thread too. Most likely related.

Share this post


Link to post

Hey CN, I have another odd one for you.

 

For the last few weeks I've been having problems with in-game notifications disappearing much faster than normal, to the extent that notifications that normally only stay on screen for a few seconds disappear instantly. I have to keep the notifications window open at all times just so I don't miss something. Sometimes it takes 20 minutes to start occurring, sometimes it only takes a few minutes, but eventually it happens without fail and seems to get worse the longer I play (meaning the notifications disappear faster and faster).

 

I've been researching and troubleshooting for a week or so with no luck finding the culprit, but last night I had a thought that the issue started right around the same time that S4CL started to be a requirement for WP. So this morning I removed WP and S4CL, loaded my game, and played for a couple of hours and the notifications worked normally the entire time. I then closed the game, only copied the S4CL files back to my Mods folder, and loaded the game again and about five minutes in the bug reappeared. I removed the files, went back to playing without them, and everything was fine again.

 

I haven't seen anyone else mention this issue, so maybe it's unique to my setup. Thoughts/suggestions? Thanks in advance.

 

Update: Ignore this. I played for hours yesterday without WP and S4CL installed and the issue never returned, but now it's back without either of those packages installed. Hopefully I can figure this out someday. Grr.

Share this post


Link to post

It not working it allows me to select to have sex with pet but the pet refuses. I have the all pet always accept sex  cheat enabled. But they still refuse 

Share this post


Link to post

I 'm having issues where even if the cheat is enabled my animal ALWAYS denies having sex with the sim? CI've even tried it with a different Male dog. Is there anyway to fix this?

Share this post


Link to post
On 1/9/2020 at 4:29 PM, ColonolNutty said:

If you are using the beta version of WP then you must also use the beta version of KW. All of my mods are compatible with each other.

I've confirmed that I have correct versions of everything (no beta; just the correct version of WW and the versions of KW and WP you've uploaded here plus the newest lib files). KW has always worked fine as expected, but still getting "no animations" for WP even with placing the animations and the files for KW, WP, and the lib files directly into my Mods folder instead of a subfolder. I know the Selectable Pets mod by AOM wasn't conflicting, so I guess now begins the hunt to figure out exactly what is conflicting.

Share this post


Link to post
6 hours ago, bade566 said:

Hi ColonolNutty, I have barely updated the game to version 1.59.73.1020 update all the mods I use but at the beginning of the game I get an error

ColonolNutty_Exception.txt 2.51 MB · 2 downloads

If you get an exception file with my name in the name of it, it is already obvious that you don't have the most up to date versions.

  

15 hours ago, RuWoytsek said:

I've confirmed that I have correct versions of everything (no beta; just the correct version of WW and the versions of KW and WP you've uploaded here plus the newest lib files). KW has always worked fine as expected, but still getting "no animations" for WP even with placing the animations and the files for KW, WP, and the lib files directly into my Mods folder instead of a subfolder. I know the Selectable Pets mod by AOM wasn't conflicting, so I guess now begins the hunt to figure out exactly what is conflicting.

The correct version is the beta. It is probably time for me to just remove the "beta" portion from the name.

Share this post


Link to post
7 hours ago, ColonolNutty said:

If you get an exception file with my name in the name of it, it is already obvious that you don't have the most up to date versions.

  

The correct version is the beta. It is probably time for me to just remove the "beta" portion from the name.

Well then, my apologies. It is the latest version you have uploaded on this site.

Share this post


Link to post
7 hours ago, RuWoytsek said:

Well then, my apologies. It is the latest version you have uploaded on this site.

No it isn't.
If it was Kinky Whims it would create a file with the name Kinky_Assault_Exception.txt, Kinky_Abduction_Exception.txt or KW_WP_Utilities_Exception.txt.
If it was Wicked Pets, it would be WickedPets_Exception.txt or KW_WP_Utilities_Exception.txt.
If it somehow bubbled up to S4CL, there would be a Sims4CommunityLib_Exception.txt file.
So again, you do not have the latest version installed
At the time of this writing the "latest" is currently version "5.0.18-beta" for KW, "7.0.17-beta" for WP, and "1.2.6" for S4CL (which isn't uploaded to LL).

Share this post


Link to post

No longer in the beta stage, all previous versions are now considered unsupported.

 

Ensure you have installed S4CL (link in the description) and that you are currently on WW version 150a

Share this post


Link to post

It not working it allows me to select to have sex with pet but the pet refuses. I have the all pet always accept sex  cheat enabled. But they still refuse. WW works fine withe cheats but WP doesn't work

Share this post


Link to post

Having a problem with getting pets to accept, Have a newer female couple with their dog and the dog is female to.. it is a no go ,moved to another older house, with a male sim and female dog, it works so the mod works right.. With the new version of WW their seems to be a gender preference (strait/gay/bi) with what seems all sims(and pets) set to strait (took me longer than I would like to admit complaining to my screen to figure that out) So tried to make the fem dog in the ladies house bi, still a no go, constant rejection.

Share this post


Link to post
4 hours ago, ColonolNutty said:

I can see errors saying something about a "WWCommonSim" object. I'd recommend you remove all versions of CNWW, because that's the last time I heard of that being a thing. You also need to use WW 150a until I update the mods.

According to me, I already deleted everything related to "CNWW", and I already have the WW150a version but an error still appears, if it cannot be resolved, I will take a break
I don't know what "WWCommonSim" refers to since I removed everything related to CNWW. Or where can you delete that file?

WickedPets_Exceptions.txt

WWPets_Exception.txt

Share this post


Link to post
2 hours ago, grim667 said:

Having a problem with getting pets to accept, Have a newer female couple with their dog and the dog is female to.. it is a no go ,moved to another older house, with a male sim and female dog, it works so the mod works right.. With the new version of WW their seems to be a gender preference (strait/gay/bi) with what seems all sims(and pets) set to strait (took me longer than I would like to admit complaining to my screen to figure that out) So tried to make the fem dog in the ladies house bi, still a no go, constant rejection.

 

 

Same here.

 

The mod works but no BI or GAY relationships allowed. (Always refusing no matter what).  Only Straight relationships are working. It's a gender preference problem.

 

 

 

 

Share this post


Link to post
7 hours ago, Zemacz said:

 

 

Same here.

 

The mod works but no BI or GAY relationships allowed. (Always refusing no matter what).  Only Straight relationships are working. It's a gender preference problem.

 

 

 

 

Mine doesn't work either way straight gay or bi

Share this post


Link to post
9 hours ago, Zemacz said:

(Always refusing no matter what). 

 

It's a WW bug. CN doesn't want to deal with it.

 

in the meantime:image.png.3e25887751e4316c3d04d7675f2dff4b.png

Share this post


Link to post
23 minutes ago, CypherDivine said:

How about some patience?

We have a mod that interacts with a broken mod, but...
 

I'll just leave it here.
image.png.413acffade8e1bf343f7ced81680cf6c.png

Share this post


Link to post
18 hours ago, bade566 said:

According to me, I already deleted everything related to "CNWW", and I already have the WW150a version but an error still appears, if it cannot be resolved, I will take a break
I don't know what "WWCommonSim" refers to since I removed everything related to CNWW. Or where can you delete that file?

WickedPets_Exceptions.txt 381.52 kB · 2 downloads

WWPets_Exception.txt 133.07 kB · 0 downloads

Remove WWPets

Share this post


Link to post
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...