Jump to content
Lithia<3

[mod] [Stellaris] Lustful Void - WIP

Recommended Posts

Hello, i'm new here and I had some problems.
The mod don't want to work (I know it's something I didn't do so, here I am)
For information: I took: -the file Lustful_Void_0.4.8.zip

-the version 2.6.3 of stellaris

-LV up of list of mode

-LV and placed it in Paradox Interactive\Stellaris\mod

-and I made LV the only mod

 

But I don't have any of the options that should be avaible (traits, origins, civics, buildings, etc), so what should I do?

thank you in advance for the future replies

from a french man

Link to post
7 hours ago, Kraii said:

Hello, i'm new here and I had some problems.
The mod don't want to work (I know it's something I didn't do so, here I am)
For information: I took: -the file Lustful_Void_0.4.8.zip

-the version 2.6.3 of stellaris

-LV up of list of mode

-LV and placed it in Paradox Interactive\Stellaris\mod

-and I made LV the only mod

 

But I don't have any of the options that should be avaible (traits, origins, civics, buildings, etc), so what should I do?

thank you in advance for the future replies

from a french man

I even tried the old version (without the new one) and it didn't work.
I went into the files to try to fix it, but whatever I try, it doesn't work.

 

So please, can I have a bit of help

Link to post
7 hours ago, Kraii said:

Hello, i'm new here and I had some problems.
The mod don't want to work (I know it's something I didn't do so, here I am)
For information: I took: -the file Lustful_Void_0.4.8.zip

-the version 2.6.3 of stellaris

-LV up of list of mode

-LV and placed it in Paradox Interactive\Stellaris\mod

-and I made LV the only mod

 

But I don't have any of the options that should be avaible (traits, origins, civics, buildings, etc), so what should I do?

thank you in advance for the future replies

from a french man

Is the mod activated in the Paradox launcher? Open the mod tab of the launcher before starting the game and slide the toggle next to a mod to enable it.

Link to post
8 hours ago, Kraii said:
-LV up of list of mode

For clarification, the load order in the Paradox Launcher is from top to bottom, meaning the mod at the top is loaded first and mod at bottom is loaded last.

Link to post
On 5/19/2020 at 3:17 AM, Anonymous said:

Weird indeed, as I checked the archive and don't see anything in the mod itself that could cause it (and I see the author already accounted for the game changing the path). Maybe reinstall the mod?

Nope, zero success.

I suppose I just have to wait for the mod to update.

Link to post
20 hours ago, BoogerHooker said:

Is the mod activated in the Paradox launcher? Open the mod tab of the launcher before starting the game and slide the toggle next to a mod to enable it.

Yes, it's the only one enable and still doesn't want to work

Link to post
19 hours ago, Anonymous said:

For clarification, the load order in the Paradox Launcher is from top to bottom, meaning the mod at the top is loaded first and mod at bottom is loaded last.

I did this way, so I would be sure it was the first to count and still didn't work

 

Link to post
1 hour ago, Kraii said:

I did this way, so I would be sure it was the first to count and still didn't work

 

It's the other way around. The mod at the bottom of the load order (i.e. loaded last) is the one you want to not be overridden by anything else.

That said, it doesn't matter if you're only using one mod.

Link to post
2 hours ago, Anonymous said:

It's the other way around. The mod at the bottom of the load order (i.e. loaded last) is the one you want to not be overridden by anything else.

That said, it doesn't matter if you're only using one mod.

Sorry. I didn't understood. My bad and thank you^^.

Link to post

Hey all. I'm having some trouble figuring out how ravage works. Playing as a Propagating swarm but no pops are abducted on ravage bombardment. Devastation is above 25. 

 

I'm also unable to change the pop rights of the species to not Undesirables, if that makes a difference?

Link to post
23 hours ago, Side2 said:

Hey all. I'm having some trouble figuring out how ravage works.

Ravage works similarly to the Raiding stance unlocked with the Nihilistic Acquisition ascension perk. You are not abducting any pops since they are undesirables, they are killed instead.

Changing their rights to anything other than undesirables would solve this but sadly the 2.7 update broke Brood Swarms, you can not set other species to anything other than undesirables, not even with the perk it says you need to unlock. We will just have to wait for either a hotfix or a new LV version.

Link to post

Need some help with this mod. Everything works fine, but when any events related to this mod happen, their images fill part or the entire screen, way past the event image box. This does not happen with vanilla events. Anybody know why this is happening? Thanks.

Link to post
6 minutes ago, Biolumina said:

Need some help with this mod. Everything works fine, but when any events related to this mod happen, their images fill part or the entire screen, way past the event image box. This does not happen with vanilla events. Anybody know why this is happening? Thanks.

Forgot to add, but I am also using the UI Dynamic Overhaul 2.6.3 mod

Link to post
18 minutes ago, Biolumina said:

Need some help with this mod. Everything works fine, but when any events related to this mod happen, their images fill part or the entire screen, way past the event image box. This does not happen with vanilla events. Anybody know why this is happening? Thanks.

They are supposed to. If you don't like it, I think there are mod settings in the Edicts tab at the bottom.

Link to post
1 hour ago, Anonymous said:

They are supposed to. If you don't like it, I think there are mod settings in the Edicts tab at the bottom.

Thanks for the quick reply, I checked the settings but I couldn't find anything about the images. so I'll just live with it I suppose.

Link to post
4 hours ago, Biolumina said:

Thanks for the quick reply, I checked the settings but I couldn't find anything about the images. so I'll just live with it I suppose.

there's another file in the download section, a patch to disable the full screen event pops and replace them with the smaller ones

Link to post

So I noticed that the breeding wars can't end even after getting the 100% exhaustion time out. This section is missing from the war goals when compared to the vanilla files.

    allowed_peace_offers = {
        status_quo
    }

 

Link to post
On 5/21/2020 at 5:56 PM, KGery said:

Ravage works similarly to the Raiding stance unlocked with the Nihilistic Acquisition ascension perk. You are not abducting any pops since they are undesirables, they are killed instead.

Changing their rights to anything other than undesirables would solve this but sadly the 2.7 update broke Brood Swarms, you can not set other species to anything other than undesirables, not even with the perk it says you need to unlock. We will just have to wait for either a hotfix or a new LV version.

Hey don't know if this may help with that or not, but back on page 52 lithia put out two patches that may help with this, I just downloaded them and yet to test it, I'll try to get back to you guys to see if it fixed it.

Link to post
On 5/17/2020 at 10:51 PM, AlteredCarbon said:

Weird, the folder location was correct but I decided to change it anyway.

That did the trick, thanks.

UPD:

Apparently that only worked for the loading screens mod but when I start creating a new Empire there's no new traits or civics there's nothing.

So looks like upon launching the game I am getting this same issue, None of my civics or traits show up from either the base game or the mod. Is there a fix for this yet? Or has someone figured out a workaround?

Link to post
51 minutes ago, TheLuckyNickel said:

So looks like upon launching the game I am getting this same issue, None of my civics or traits show up from either the base game or the mod. Is there a fix for this yet? Or has someone figured out a workaround?

The new launcher is buggy, sometimes I've had to reinstall the launcher itself to get it to work. it should appear in the programs area of your settings menu as "Paradox Launcher V2". Simply uninstall that, and fire up your game to reinstall it. You can also clean out any files from the launcher in your Appdata folder to be even more thorough. Also are you sure you aren't accidentally nestling the folders for the mod?? As in you've extracted the files wholesale and have accidentally have the folder structure being "mod/Lustful Void/Lustful Void/etc" or something similar instead of "mod/Lustful Void/etc"??

 

Edit: The "etc" in the file paths I mentioned represent all the folders and files that make up the mods such as "common, events, gfx, interface, localization, sound folders and the descriptor file.

Link to post
33 minutes ago, Railgunner2160 said:

The new launcher is buggy, sometimes I've had to reinstall the launcher itself to get it to work. it should appear in the programs area of your settings menu as "Paradox Launcher V2". Simply uninstall that, and fire up your game to reinstall it. You can also clean out any files from the launcher in your Appdata folder to be even more thorough. Also are you sure you aren't accidentally nestling the folders for the mod?? As in you've extracted the files wholesale and have accidentally have the folder structure being "mod/Lustful Void/Lustful Void/etc" or something similar instead of "mod/Lustful Void/etc"??

 

Edit: The "etc" in the file paths I mentioned represent all the folders and files that make up the mods such as "common, events, gfx, interface, localization, sound folders and the descriptor file.

So that seemed to work to an extent, I can now create a new empire with all the civics and traits, however one of my empires does not allow me to add civics or traits while the other empire I had removed all it's adult content oriented traits. Seems like a good old case of corrupt files which is annoying but it's not like it's impossible for me to rewrite the bios and what not. Thanks for your help! It did turn out that the double foldering you mentioned was the issue.

Link to post
On 5/13/2020 at 1:23 PM, Railgunner2160 said:

There is a hotfix for 2.7 on the discord, full release of the 2.7 update is "I will probably have the new LV update done this week or around the start of next week." as posted by Lithia.

Thanks for the heads up!

I've not played Stellaris in over a year and was thinking about another round, but not sure if I should try it with the current version or not.

If it's getting updated soon I might as well wait a little bit longer.

Link to post

Thank you so much for this mod. But I sometimes have trouble when the pictures that are suppose to be larger become small again. How do I fix that? Such as when special events from the mod pop up, some times they come up big and other times they go to the standard Stellaris notification. But that is only when I start a new game that they switch back and forth.

Link to post

Hi all, how do you make a custom trait for lustful void and make it work in game? and events? As I wanted to take the futa trait and combine it with different different  LV traits. Haven't decided on whitch ones yet but I wanted it to effect modifiers like sex/milk/etc job output but have doubbed the consumer goods/ food upkeep for all them sex toys n energy for sexy time. I don't know how to do this or how to do the localisation file are there any guides or can someone share their own version, I can't be the only person to want this kind of thing?

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...