Jump to content
Lithia<3

[mod] [Stellaris] Lustful Void - WIP

Recommended Posts

10 hours ago, Thredra said:

Got an issue I need help with. My Stellaris game does not acknowledge that I have mods installed that weren't installed via Steam Workshop. I've tried going back to 2.2.7, but that didn't work and I start it up through steam so I don't have a Paradox Launcher to reinstall.

Edit: I got it to work. Had to uninstall Launcher V2, reinstall the game, then extract the mod into the mod folder and have all the mod files in the same mod folder. 

Pretty sure just extracting the mod and making sure the [mod_name].mod file had a correct path set would've been enough.

Link to post
1 hour ago, Railgunner2160 said:

There is a hotfix for 2.7 on the discord, full release of the 2.7 update is "I will probably have the new LV update done this week or around the start of next week." as posted by Lithia.

yep found it earlier. thank you for posting this so others may know

Link to post
7 hours ago, Railgunner2160 said:

There is a hotfix for 2.7 on the discord, full release of the 2.7 update is "I will probably have the new LV update done this week or around the start of next week." as posted by Lithia.

Awesome!  Thanks!

Link to post

Sorry, I wanted to upload the fixes here too butt forgot. Here's exactly what I said and linked on the discord server:

 

So I know I've been a bit inactive, just busy with some rl things. I decided to make a quick patch for some of the bigger problems with the currently released version. I wanted to bundle it with the unreleased one, but I'm still adding new things to that. You need to overwrite 0.4.8 with this (not the other way around lol). Next update should be out in a few weeks 😉

 

And:

 

Here's a hotfix for the new stellaris 2.7.1 update. You should use the above overwrite patch first (if you haven't yet) and then overwrite AGAIN with this hotfix. Also, ignore the version warning for LV in the launcher. All these changes are already part of the unreleased version so don't worry, all this overwriting is just temporary! I will probably have the new LV update done this week or around the start of next week.

 

---

So, overwrite with "Lustful_Void_0.4.8_Overwrite_Patch" FIRST and then "Lustful_Void_0.4.8_Hotfix_2.7.1_Overwrite".

Lustful_Void_0.4.8_Overwrite_Patch.zip Lustful_Void_0.4.8_Hotfix_2.7.1_Overwrite.zip

Link to post

So I am new to Stellaris as a game. Running in vanilla base game, no DLCs currently. 

This this mod DLC dependent? Initial page 1 mentions it should run, but is there any personal experience out there for vanilla with using this?

Link to post
12 hours ago, Furaden said:

Does anyone else have the problem of livestock pops taking streetwalker jobs? I have doubts this is intentional.

Might not be intentional, but maybe this could be unlocked as a hilarious civic choice if you think about it :P

Link to post
4 hours ago, thelordofroses said:

document->paradox interactive->stellaris-> mod must exist. then youmust extract contents too the folder ensuring the lustful void .mod file is in the mod folder and not the lustful void folder. then apply the patches as previously mentioned. 

Do I need to put the patches in LV folder or mods?

Link to post
5 hours ago, thelordofroses said:

document->paradox interactive->stellaris-> mod must exist. then youmust extract contents too the folder ensuring the lustful void .mod file is in the mod folder and not the lustful void folder. then apply the patches as previously mentioned. 

I put it there and it shows up in the launcher but nothing changes 

Link to post
On 5/15/2020 at 2:11 PM, Schmee said:

Might not be intentional, but maybe this could be unlocked as a hilarious civic choice if you think about it :P

Fixed it manually. They also took jobs from other mods, probably it's an issue with civic (forgot the name) that was giving lifestock -3 food and + unity

Link to post
12 hours ago, AlteredCarbon said:

installed as described and the launcher acknowledges that the mod is installed

none of the mod contents show up in-game however

Go to "Documents\Paradox Interactive\Stellaris\mod" and open "Lustful Void.mod" with any text editor. Check if the folder location in the "path=" is correct (i.e. referencing your machine, not some random guy), if not change it to:

path="mod/Lustful Void"

That ought to do it.

Link to post
20 hours ago, Anonymous said:

Go to "Documents\Paradox Interactive\Stellaris\mod" and open "Lustful Void.mod" with any text editor. Check if the folder location in the "path=" is correct (i.e. referencing your machine, not some random guy), if not change it to:


path="mod/Lustful Void"

That ought to do it.

Weird, the folder location was correct but I decided to change it anyway.

That did the trick, thanks.

UPD:

Apparently that only worked for the loading screens mod but when I start creating a new Empire there's no new traits or civics there's nothing.

Link to post
16 hours ago, AlteredCarbon said:

Weird, the folder location was correct but I decided to change it anyway.

That did the trick, thanks.

UPD:

Apparently that only worked for the loading screens mod but when I start creating a new Empire there's no new traits or civics there's nothing.

Weird indeed, as I checked the archive and don't see anything in the mod itself that could cause it (and I see the author already accounted for the game changing the path). Maybe reinstall the mod?

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...