Jump to content
gatto tom

Dead or Alive 6 - Modding Thread and Discussion

Recommended Posts

1 hour ago, fgh1t6 said:
  Hide contents

 

Can you run the "Assign new 3DMigoto vertex groups" in 2.82? It seems the F3 search won't find the script because the function was not be added into any menu. 

Worked to me with 2.80, but not with newer versions. I just move to 2.79 and use it in a sec

Link to post
1 hour ago, Azkni said:

Worked to me with 2.80, but not with newer versions. I just move to 2.79 and use it in a sec

try this one for 2.82 upper then:  blender_3dmigoto.py, nothing too fancy just add that script to the end of the "Object" tab, and change the default number from 1 to 3 to save us one typing.

Link to post
11 hours ago, Azkni said:
  Reveal hidden contents

image.png.634c965c2b9723048df75bdea8af5ddf.png

Go to weight paint mode and select the vertex group that u want (in your case the head i guess but its up to you xd) and just paint till everything is red (maybe the tool with blue circle in the screnshot makes things faster for you)

About the hair still not showing up, I recommend to use a new hon_hair_001.g1m, those files bug a bit when you import and export them a lot. Also check twice that your UVmap is fixed! 

Or if you didnt weight paint it yet maybe it is just not in the correct place and it is floading 10m away from the correct place

its better to share the files and I can check, its faster than trying to guess what went wrong u.u

I tried all of this (even replacing the g1m file, in fact I had technically already been doing this) and she's still bald. Something I did notice though is that the UV map seems to disappear when switching to Weight Paint

Link to post
1 hour ago, BeeLy1011 said:

I tried all of this (even replacing the g1m file, in fact I had technically already been doing this) and she's still bald. Something I did notice though is that the UV map seems to disappear when switching to Weight Paint

 

 That is normal, UV map only show up in edit mod. upload your  hon_hair_001.g1m file, and the content of mod.ini so that we can have a look on it.

Link to post
6 hours ago, fgh1t6 said:

try this one for 2.82 upper then:  blender_3dmigoto.py, nothing too fancy just add that script to the end of the "Object" tab, and change the default number from 1 to 3 to save us one typing.

Yay! Thx so much!

Link to post

I have a question for all the modders in our community. I'm currently trying to use the underwear from Kasumi's costume 31 with the Kasumi costume 30. Every time I try to join mesh for the costume, it infinite loads my game. I have checked the mesh for any UV mapping but on the costume 30 it doesn't have for the bikini. The mesh for costume 31 is different than costume 30. I wanna use the costume 31 mesh for the body because it works with the underwear. The bikini top and chest doesn't work with costume 31.Is there a way to combine this and have it working? Any help would be deeply appreciated.

Link to post
8 hours ago, marik86 said:

I have a question for all the modders in our community. I'm currently trying to use the underwear from Kasumi's costume 31 with the Kasumi costume 30. Every time I try to join mesh for the costume, it infinite loads my game. I have checked the mesh for any UV mapping but on the costume 30 it doesn't have for the bikini. The mesh for costume 31 is different than costume 30. I wanna use the costume 31 mesh for the body because it works with the underwear. The bikini top and chest doesn't work with costume 31.Is there a way to combine this and have it working? Any help would be deeply appreciated.

That is almost a one-to-one exchange. You can try to joint the underwear mesh from 31 to 30's bikini brief, delete the vertex of the bikini brief, and then do whatever you did to export it the game to test if it works. Next, do the same to the body mesh, but this time, delete the vertex from 31 as much as possible. Then merge the overlapped vertices.

Link to post
10 hours ago, fgh1t6 said:

That is almost a one-to-one exchange. You can try to joint the underwear mesh from 31 to 30's bikini brief, delete the vertex of the bikini brief, and then do whatever you did to export it the game to test if it works. Next, do the same to the body mesh, but this time, delete the vertex from 31 as much as possible. Then merge the overlapped vertices.

 

I have the bikini bottom sorted out, but the bone texture for the body is not going well. This was after I combined the lower body mesh of 31 with the upper body mesh of 30. (Sorry Administrators as I don't know how to shorten images just yet.)

20210408174021_1.jpg

Link to post
1 hour ago, marik86 said:

 

I have the bikini bottom sorted out, but the bone texture for the body is not going well. This was after I combined the lower body mesh of 31 with the upper body mesh of 30. (Sorry Administrators as I don't know how to shorten images just yet.)

yep, typical effect of forgetting to run "Assign new 3DMigoto vertex groups" script before export. For blender 2.7x pace bar then type "Assign new 3DMigoto vertex groups", to run. for 2.82, if you cannot find it with F3 key, try my edit version of blender_3dmigoto: 

 

On 4/7/2021 at 4:45 PM, fgh1t6 said:

try this one for 2.82 upper then:  blender_3dmigoto.py, nothing too fancy just add that script to the end of the "Object" tab, and change the default number from 1 to 3 to save us one typing.

 

Link to post
On 4/8/2021 at 7:03 PM, fgh1t6 said:

yep, typical effect of forgetting to run "Assign new 3DMigoto vertex groups" script before export. For blender 2.7x pace bar then type "Assign new 3DMigoto vertex groups", to run. for 2.82, if you cannot find it with F3 key, try my edit version of blender_3dmigoto: 

 

 

 

I've tried to assign new vertex, but still have same results. The bikini top bone mesh is messed up as well (I tried to assign new vertex to it as well). If anyone can help out I'd appreciate it. I have another project I'm working on atm so I won't be able to work on this for a while. Here are the mesh that I've done so far.

mesh.7z

Link to post
4 hours ago, marik86 said:

 

I've tried to assign new vertex, but still have same results. The bikini top bone mesh is messed up as well (I tried to assign new vertex to it as well). If anyone can help out I'd appreciate it. I have another project I'm working on atm so I won't be able to work on this for a while. Here are the mesh that I've done so far.

There is no vgmap with your files, and the bones are all in raw numbers. You have extracted the mesh in a non-standard way. Use the "g1m_export_with_vgmap.bat" to extract the meshes. or if you have the *.vgmap files, use apply them to the mesh with "import -> Apply 3Dmigoto vertex group map to current object".

Link to post
On 11/25/2020 at 9:52 AM, fgh1t6 said:

 

1. for texture, use g1t tool, you can put any size dds into the g1t file, and it works fine.

2. for transparency, you can use g1m_xml tool to modify any g1m file's material setting to make one. You can convert the following g1m to xml to have a look

  Hide contents

 

 

Check the

<G1M version="37">

    <G1MG version="44" platform="DX11">

        <MeshesSection>

            <LodGroup idx="0" auto="true">

                <Mesh idx="2">
                    <Shader value="@37639FF9" />
                </Mesh>

 

"37639FF9" is binary transparent shader code. No attribute setting is needed.

 

 

 

I have some questions about transparency , how to know which <Mesh idx="X"> I must change ? For example , I checked your SKD_COS_031.g1m for that leaf mod ,-<Mesh idx="2"> and -<Mesh idx="3"> useing the 37639FF9 code , why these two rather than  0 or 1 or 3 ...? In blender , the number of the bra parts is 0 and 1 , so how do I know which Mesh idx need change ? And if I want make transparency , only increase a alpha channel in dds to kidsalb right ?

Link to post
8 hours ago, z31wnx said:

I have some questions about transparency , how to know which <Mesh idx="X"> I must change ? For example , I checked your SKD_COS_031.g1m for that leaf mod ,-<Mesh idx="2"> and -<Mesh idx="3"> useing the 37639FF9 code , why these two rather than  0 or 1 or 3 ...? In blender , the number of the bra parts is 0 and 1 , so how do I know which Mesh idx need change ? And if I want make transparency , only increase a alpha channel in dds to kidsalb right ?

The idx doesn't matter, you can add your own one too. in fact, the idx may be changed by the g1m_xml.exe during regenerate the g1m file. In the <mesh idx=xx> block, there is a <submeshes value="x">, that "x" is the mesh index using this setting. So for the Bra, that will be <submeshes value="0">.

 

For transparency, it is far more complicated than changing dds.  There are thousands "Shader value" defined in the Character.sid file, and the hash of the setting files has been digged out  by vago's  and list in the g1m_tool package's "sid_alt-hash.txt". Only a few has been used in g1m files, and only very few has been tested, and shared out. Basically there are three type of mesh: normal, softbody, and clothe (or 4D, used by us). Each type use different set of shaders, if use wrongly, game crash.

Now for the transparent shaders, most of them need to set the mesh type in the "  <Submesh idx="x">" block,  and a Attribute setting of "fRpAlphaThres" plus the correct shader hash. However, the good news is for binary transparency only, we found two shaders don't request these settings: @37639FF9 for normal mesh, and @003AED6F for softbody.

Link to post
On 4/10/2021 at 11:50 PM, Azkni said:

Is there a way to add kidsalem textures to any costume like any XXX_COS_036 costumes have? Like for example add it to Brad Wong delux so it shines at the dark 

Simple answer is Yes!

Detail is:

first of all, the .kts file list must has the alem entry. in .kts file, looking for ", 0, 19 , 0,  4, 4", if not found (of course!) ,  replace the shl one (, 0,37,37,4,4), since it seems they cannot be used at the same time anyway. And yep, use the shl's g1t file too.

 

2nd, go to xml file's "<MaterialsSection>" and the block for that kts set, say    <Material idx="0">, replace the poor shl's entry

                <Texture id="5" type="0" type2="37" u_06="37" u_08="4" u_0a="4" />

to alem

                <Texture id="5" type="0" type2="19" u_06="0" u_08="4" u_0a="4" />

than, go to the corresponding "<AttributesSection>/<MaterialAttributes idx="?">" copy the following attributes from cos036: "Attribute name="aleScl", and "Attribute name="alePMPrms" . the first number of alePMPrms, is the flash speed. say, 0.3 is flash in 1/0.3 seconds, 0 means no changing, 

and finally of course the Shader hash, from cos036, I got two: @5DE4D28B/ @762C3826 don't know what is difference.

 

Link to post
Spoiler

 

5 hours ago, fgh1t6 said:

Simple answer is Yes!

Detail is: There are a few things involved:  first of all, the .kts file list must has the alem entry. in .kts file, looking for "#, 0, 19 , 0,  4, 4", if not there (of course not) ,  replace the shl one (#, 0,37,37,4,4), since it seems they cannot be used at the same time anyway. And yep, use the shl's g1t file too.

2nd, go to xml file's "<MaterialsSection>" and the block for that kts set, say    <Material idx="0">, replace the poor shl's entry

                <Texture id="5" type="0" type2="37" u_06="37" u_08="4" u_0a="4" />

to alme

                <Texture id="5" type="0" type2="19" u_06="0" u_08="4" u_0a="4" />

than, go to the corresponding "<AttributesSection>/<MaterialAttributes idx="?">" copy the following attributes from cos036: "Attribute name="aleScl", and "Attribute name="alePMPrms" . the first number of alePMPrms, is the flash speed. say, 0.3 is flash in 1/0.3 seconds, 0 means no changing, 

and finally of course the Shader hash, from cos036, I got two: @5DE4D28B/ @762C3826 don't know what is difference.

 

YOO!! (the physics of the rope are bugged tho idk)

And maybe its just me but I notice using @762C3826 hash makes them look more saturated (?)

Also have no idea why is it blue hahaha! Thought I would need to modify textures too but wasnt needed  Thx so much dude

 

image.png

Link to post
4 minutes ago, Azkni said:
  Reveal hidden contents

 

YOO!! (the physics of the rope are bugged tho idk)

And maybe its just me but I notice using @762C3826 hash makes them look more saturated (?)

Also have no idea why is it blue hahaha! Thought I would need to modify textures too but wasnt needed  Thx so much dude

 

image.png

Ok this thing just encouraged me to mod a bit more omg!

I changed the 0.3 to 10 and this is how it looks for some reason Brad lights also has the same speed but his number is 0.3 (probably the hash(?))

Link to post
2 hours ago, Azkni said:
  Reveal hidden contents

 

YOO!! (the physics of the rope are bugged tho idk)

And maybe its just me but I notice using @762C3826 hash makes them look more saturated (?)

Also have no idea why is it blue hahaha! Thought I would need to modify textures too but wasnt needed  Thx so much dude

 

image.png

Hey it's APO from twitter! Do you have a new page? 😄

Link to post

Hello everyone, I have some question for modders.
Basically I'm trying to use Marie tied hair for Christie but a simple swap with work line doesn't do the cut. The set is off and the hair buried inside Christie's head.
So I try to extract the g1m files of it, got 69 vbs files, I put it on blender, selected all and scale it uniformly. Unfortunately after painstakingly exporting 69 VB files one by one(at this point I really wish there's a batch export for 3Dmigoto addon) and imported it to the g1m files again, the game machine BROKE the game crashes.
1579809683_Screenshot(239).png.647cf6baffc459d300b4dee6cbd34c3d.png

 

So I'm stumped and not sure what to do anymore, can someone help me how to adjust the position of simple hair swap that works?

 

On the side note, I though simply to adjust the scale and height on Blender in edit mode could do is because I made this by using that method and it seems fine:

Spoiler

838174372_Screenshot(240).png.3e265a54435a41f973b55c96d70beef4.png

^Although this one only have 2 vbs.

 

EDIT: Okay nevermind, apparently Marie's ponytail have 4D meshes, simply resizing the compatible meshes lead to crash, so I change to Kasumi's hair.

Link to post
2 hours ago, BeeLy1011 said:

The UVmap isnt fixed, did u do the following?

On 4/7/2021 at 12:39 AM, Azkni said:
  Reveal hidden contents

image.png.1a055a22ebd6c789d2229256c05b42fd.png

The UVmap that shows up to me is this one, and if u check that left corner of the hair texture it is completly transparent, thats why it doesnt show up. To solve it you have to change the UV map, delete TEXTCOORD.xy and rename UvMap as TEXTCOORD.xy, now u should see that your UVmap has more sense ;D

 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

×
×
  • Create New...