Jump to content
Locuturus

[Starbound] Sexbound

Recommended Posts

Okay, here's a better version. It'll automatically open its output folder, just zip all the files in it and send them here. It'll probably take a couple minutes for it to run.

Again, just a batch file that unpacks all assets and copies all bdata to a new folder.

(The number attached to the bdata file is its steam id.)

 

test.bat

Share this post


Link to post

I am having an issue with the sandbox not working. When I active the hearts over any bed the position menu pops up but no matter what I click on the player character just lies in the bed.

Share this post


Link to post
49 minutes ago, pyrobladeich said:

I am having an issue with the sandbox not working. When I active the hearts over any bed the position menu pops up but no matter what I click on the player character just lies in the bed.

... i mean... yeah...?

I haven't seen the Sandbox myself, as i've been rather toasted on Starbound devvin' over the holidays and new year break, but sounds like you're saying that you lay in a bed, by yourself, and expect there to be some animations playing. Solo isn't a thing yet*. If there is someone else joining you, feel free to drop a starbound.log into the message. Instructions are at hand if you need them. Unless you're trying to use the Sexbound-test objects with included NPC's, those shouldn't be working, since 3.4 kinda broke object-NPC's.

 

*Hopefully being worked on, but there are other issues at hand that currently debilitate the functions of Sexbound. Specifically, issues regarding older species supports causing sexbound-beds to be essentially disabled.

Share this post


Link to post

whenever i try to do the quest for aphrodites bow, after the boss battle i dissapear on the furniture with aphrodite. 

Share this post


Link to post

Uhh, Im using sexbound 3.0.0 and basically used all the v3 mods I could use
the aphrodite's bow doesn't seem to work, is there any other mod I can use the same way how I can use the bow?

Share this post


Link to post
3 hours ago, shamelessfurman said:

Uhh, Im using sexbound 3.0.0 and basically used all the v3 mods I could use
the aphrodite's bow doesn't seem to work, is there any other mod I can use the same way how I can use the bow?

The lewdguns from Lewdbound, albeit much less versatile and usable than the bow, can and will work the same. Though i must ask, how so? How does the Aphrodite's Bow not work?

Share this post


Link to post

Having a bit of an issue, Long absence from Starbound and returned to fresh install and only install Sexbound. Everytime i bootup the game it is instantly closing after chucklefish laughs.

Any idea what's going on? Running the newest version of the game no additional content installed all files verified ETC. I'm not tech savvy so i'm at a loss here :x Any help is appreciated!

Using the .zip file 3.4.1.src -> Winrar Extraction if that helps.

 

Edit: 2020 - 02 - 07

 

Starbound is running fine with other mods but whenever i pop Sexbound into the x86 steam common starbound mod file it just breaks after chuckles.

 

Completely forgot to mention this in my original post.

Share this post


Link to post
On 2/6/2020 at 12:34 PM, shamelessfurman said:

Uhh, Im using sexbound 3.0.0 and basically used all the v3 mods I could use
the aphrodite's bow doesn't seem to work, is there any other mod I can use the same way how I can use the bow?

just throwing it out there, but it is the imbued version right? 
but yeah the shotgun lewdgun thing works too, but also makes quite a mess ;) 

Share this post


Link to post
13 hours ago, BB520 said:

Having a bit of an issue, Long absence from Starbound and returned to fresh install and only install Sexbound. Everytime i bootup the game it is instantly closing after chucklefish laughs.

Any idea what's going on? Running the newest version of the game no additional content installed all files verified ETC. I'm not tech savvy so i'm at a loss here :x Any help is appreciated!

Using the .zip file 3.4.1.src -> Winrar Extraction if that helps.

 

Edit: 2020 - 02 - 07

 

Starbound is running fine with other mods but whenever i pop Sexbound into the x86 steam common starbound mod file it just breaks after chuckles.

 

Completely forgot to mention this in my original post.

Ey, sounds like you may have installed it improperly. BUT! Posting a log can help you explain us what happened if it's more than the case.

Share this post


Link to post

Me and a friend are trying to do multiplayer sexbound on a steam based friend to friend connection, were using one of the versions before 3.0, i cant remember which at the moment, but one of the mods isnt playing nice. If someone would be willing to help me find the issue it would be much appreciated, i have my friends log attached

starbound log copy.pdf

Share this post


Link to post
8 minutes ago, MaxisGarfield said:

Me and a friend are trying to do multiplayer sexbound on a steam based friend to friend connection, were using one of the versions before 3.0, i cant remember which at the moment, but one of the mods isnt playing nice. If someone would be willing to help me find the issue it would be much appreciated, i have my friends log attached

starbound log copy.pdf 94.46 kB · 0 downloads

No Sexbound or any local mods are even installed in this log, but okay.

[15:30:07.351] [Error] You were disconnected from the server for the following reason:
Incoming client packet has caused exception

This error doesn't specify anything wrong, just comes up when A and B don't have the same mods. Considering there are literally no local mods and no Sexbound, you probably can't connect to each other because of that. Otherwise, make sure you two are sharing the exact same mods and no more/less.
 

 

Share this post


Link to post
5 minutes ago, red3dred said:

No Sexbound or any local mods are even installed in this log, but okay.


[15:30:07.351] [Error] You were disconnected from the server for the following reason:
Incoming client packet has caused exception

This error doesn't specify anything wrong, just comes up when A and B don't have the same mods. Considering there are literally no local mods and no Sexbound, you probably can't connect to each other because of that. Otherwise, make sure you two are sharing the exact same mods and no more/less.
 

 

odd, she must be installing in the wrong place, thanks ill see it fixed

Share this post


Link to post
34 minutes ago, MaxisGarfield said:

she has all the mods in the mods folder, i cant figure out what the issue is

So, i've cleared up the log for easier reading on my end, i'll attach the non-copy-pasted into a PDF file, and i'll denote this:
image.png.3257a0e6623d3d010e94823941347b53.png

 

The game explicitly states it doesn't find anything in the mods folder. Either they made a new folder, or put the mods elsewhere entirely, but it's in neither folders that would be valid (assets or mods). Depending on the security options of their OS, they may have pasted the files in there, but the system doesn't allow them to be loaded. At any rate, this is all i can do from this end, since there aren't any Sexbound errors yet...

 

ClearedUpLog.log


Otherwise a handful of errors from other mods. TF2's mod is pretty heavily outdated and generally not well kept in terms of fixing. FFS (Feast of Fire and Smoke) consistently throws out errors for every user, albeit it works just fine. Nothing detrimental to running the game, i don't think.

Share this post


Link to post

thanks anyway

31 minutes ago, red3dred said:

So, i've cleared up the log for easier reading on my end, i'll attach the non-copy-pasted into a PDF file, and i'll denote this:
image.png.3257a0e6623d3d010e94823941347b53.png

 

The game explicitly states it doesn't find anything in the mods folder. Either they made a new folder, or put the mods elsewhere entirely, but it's in neither folders that would be valid (assets or mods). Depending on the security options of their OS, they may have pasted the files in there, but the system doesn't allow them to be loaded. At any rate, this is all i can do from this end, since there aren't any Sexbound errors yet...

 

ClearedUpLog.log 69.36 kB · 0 downloads


Otherwise a handful of errors from other mods. TF2's mod is pretty heavily outdated and generally not well kept in terms of fixing. FFS (Feast of Fire and Smoke) consistently throws out errors for every user, albeit it works just fine. Nothing detrimental to running the game, i don't think.

thanks anyway

Share this post


Link to post

Is a foursome available at this time? I seem to only get a threesome and was wondering if it was implemented yet.

 

And is there no futanari sprite? I enabled it in the sexbound.config but it's not showing up.

 

 

Share this post


Link to post
1 hour ago, OtakuLegend said:

Is a foursome available at this time? I seem to only get a threesome and was wondering if it was implemented yet.

Bruh we just got threesomes out - And well, the API supports it, we just don't have artwork made for it, threesomes use recycled animations so 4's would require a lot more work to fit it all and not look bad.

 

1 hour ago, OtakuLegend said:

And is there no futanari sprite? I enabled it in the sexbound.config but it's not showing up.

The Futanari sprite is just females with the added groin layer, it should be noticeable. If you enable the Futanari module, it only affects Floran Females by default. Tips on how to setup that can be provided if needed.

Share this post


Link to post
13 minutes ago, red3dred said:

Bruh we just got threesomes out - And well, the API supports it, we just don't have artwork made for it, threesomes use recycled animations so 4's would require a lot more work to fit it all and not look bad.

 

The Futanari sprite is just females with the added groin layer, it should be noticeable. If you enable the Futanari module, it only affects Floran Females by default. Tips on how to setup that can be provided if needed.

I figured out the futanari thing. :D

 

And I didn't know when threesomes came out, only recently started getting into starbound and sexbound. My bad G

 

Thanks for the reply tho

Share this post


Link to post

hello am trying to do a dedicated server for me and friends and i got a issue and my question is : is the mods compatible with dedicated servers if yes  how to fix the " [Error] Could not instantiate item '[sexbound1-codex, 1, {}]'. (ItemException) No such item 'sexbound1-codex' " if you need the server logs

[17:45:46.318] [Info] UniverseServer: Client 'Kiku' <8> (109.208.179.247) connected
[17:45:46.325] [Info] UniverseServer: Creating new client ship world ClientShipWorld:a4e5e1f57816d7d9b3cc7448a66dce5e
[17:45:46.345] [Info] Protected dungeonIds for world set to (65524)
[17:45:46.352] [Info] UniverseServer: Creating temporary instance world 'InstanceWorld:protectorate:a4e5e1f57816d7d9b3cc7448a66dce5e:-' with expiry time 0
[17:45:46.387] [Info] Protected dungeonIds for world set to (65524)
[17:45:46.390] [Info] Placing dungeon protectorate
[17:45:46.426] [Info] Placing dungeon at (0, 1000)
[17:45:47.892] [Info] Flying ship for player 8 to new starter world
[17:45:47.897] [Info] Searching for new randomized starter world
[17:45:47.930] [Info] UniverseServer: Stopping idle world ClientShipWorld:a4e5e1f57816d7d9b3cc7448a66dce5e
[17:45:55.701] [Warn] Failed to place dungeon object: protectoratesmokegen direction: 1 position: (687, 801)
[17:45:55.705] [Warn] Failed to place dungeon object: protectoratesmokegen direction: 1 position: (717, 801)
[17:45:55.713] [Warn] Failed to place dungeon object: protectoratefbannertorn1 direction: 1 position: (725, 802)
[17:45:56.077] [Warn] Failed to place dungeon object: protectoratesmokegen direction: 1 position: (703, 826)
[17:45:56.085] [Warn] Failed to place dungeon object: protectoratesmokegen direction: 1 position: (703, 827)
[17:45:56.098] [Warn] Failed to place dungeon object: protectoratesmokegen direction: 1 position: (700, 828)
[17:45:58.488] [Info] UniverseServer: Found randomized starter world at 790171964:-201065810:-138668293:3
[17:45:58.584] [Info] UniverseServer: Creating new system world at location (790171964, -201065810, -138668293)
[17:45:58.598] [Info] UniverseServer: Creating celestial world 790171964:-201065810:-138668293:3
[17:45:58.919] [Info] Protected dungeonIds for world set to (0, 65524)
[17:45:58.993] [Info] Protected dungeonIds for world set to (65524)
[17:45:58.996] [Info] Placing dungeon naturalcave
[17:45:59.000] [Info] Placing dungeon at (1777, 675)
[17:45:59.866] [Warn] Failed to place dungeon object: metalbarrel1 direction: 1 position: (2050, 465)
[17:45:59.904] [Warn] Failed to place dungeon object: metalbarrel1 direction: 0 position: (1916, 500)
[17:45:59.982] [Warn] Failed to place dungeon object: metalbarrel1 direction: 0 position: (1966, 512)
[17:46:00.065] [Warn] Failed to place dungeon object: metalbarrel1 direction: 1 position: (1836, 533)
[17:46:00.108] [Warn] Failed to place dungeon object: metalbarrel1 direction: 1 position: (1466, 551)
[17:46:00.207] [Warn] Failed to place dungeon object: metalbarrel1 direction: 1 position: (1665, 565)
[17:46:00.260] [Warn] Failed to place dungeon object: oillantern1 direction: 0 position: (1901, 569)
[17:46:01.175] [Info] Placing dungeon gardengate
[17:46:01.179] [Info] Placing dungeon at (431, 675)
[17:46:01.353] [Info] Protected dungeonIds for world set to (1, 65524)
[17:46:04.865] [Info] UniverseServer: Warping player 8 to InstanceWorld:protectorate:a4e5e1f57816d7d9b3cc7448a66dce5e:-
[17:46:06.619] [Error] Could not instantiate item '[sexbound1-codex, 1, {}]'. (ItemException) No such item 'sexbound1-codex'
[17:46:06.631] [Error] WorldServerThread exception caught handling incoming packets for client 8: (EofException) Failed to read full buffer in readFull, eof reached.
[0] 4514da
[1] 4502c8
[2] 3e6d05
[3] 3f311e
[4] 3eb41a
[5] 3eb4b0
[6] 541f42
[7] 542c56
[8] 543c8a
[9] 4305fe
[10] 4305fe
[11] 430a4e
[12] 4f5de5
[13] 6aeb16
[14] 89a20f
[15] 8accaf
[16] 8ac7ca
[17] 44de9c
[18] 75596a14 BaseThreadInitThunk
[19] 774ead8f RtlInitializeExceptionChain
[20] 774ead5a RtlInitializeExceptionChain
[17:46:06.661] [Info] UniverseServer: Client 'Kiku' <8> (109.208.179.247) disconnected for reason: Incoming client packet has caused exception
[17:46:06.668] [Info] UniverseServer: Stopping idle world InstanceWorld:protectorate:a4e5e1f57816d7d9b3cc7448a66dce5e:-
[17:46:09.468] [Info] UniverseServer: Expiring temporary world InstanceWorld:protectorate:a4e5e1f57816d7d9b3cc7448a66dce5e:-
[17:46:09.645] [Info] UniverseServer: Stopping idle world CelestialWorld:790171964:-201065810:-138668293:3
[17:46:16.753] [Info] UniverseServer: Reaped 1 dead connections 

It's from the last throwable character i create to connect
 

Share this post


Link to post
10 hours ago, hitman2b said:

hello am trying to do a dedicated server for me and friends and i got a issue and my question is : is the mods compatible with dedicated servers if yes  how to fix the " [Error] Could not instantiate item '[sexbound1-codex, 1, {}]'. (ItemException) No such item 'sexbound1-codex' " if you need the server logs

It's from the last throwable character i create to connect

Well, yes, there is even a dedicated server running Sexbound among other mods. That error just says it could not create the codex, which means it was either not installed properly on the client or the server, though it sounds like client. If it was a server side error it'd probably either say EoF or "No such item Sexbound-Codex1". At any rate, yes it is totally possible to host a dedicated Sexbound server and it does work.

Share this post


Link to post

Updated from 2.13 to 3.4.1 but when i use the 3.4.1 version i can't use the louangable furniture even the bow doesn't work when i shoot npc's nothing happens not even the obstructed error but on 2.13 everything worked fine i could use the bow and even the loungable furniture with the hearts above it

 

and when the heart above the bed works for (whatever reason) makes my char invisible and the npc too

 

the npc and my char are both floran so it shouldn't be a custom species error

Share this post


Link to post
25 minutes ago, Exanimalus said:

Updated from 2.13 to 3.4.1 but when i use the 3.4.1 version i can't use the louangable furniture even the bow doesn't work when i shoot npc's nothing happens not even the obstructed error but on 2.13 everything worked fine i could use the bow and even the loungable furniture with the hearts above it

 

and when the heart above the bed works for (whatever reason) makes my char invisible and the npc too

 

the npc and my char are both floran so it shouldn't be a custom species error

Quote

So, to better report issues, try providing a log file and a description of the issue.

To find the log file, it should be within your Starbound installation directory, then the storage folder. You should see a text file named starbound.log (Or simply starbound, a plain text file). Paste it into your response as a attached file, or use PasteBin, whichever you prefer. Then users can look into your issues with the necessary information at hand.

 

<Just please don't post the whole thing as text here>

Share this post


Link to post

Here is the log file i could also post a screenshot of the mods i use if that would help in anway (i also noticed that for some reason the reverse cowgirl animation is not shown on the newest version)

starbound.log

Share this post


Link to post
33 minutes ago, Exanimalus said:

Here is the log file i could also post a screenshot of the mods i use if that would help in anway (i also noticed that for some reason the reverse cowgirl animation is not shown on the newest version)

starbound.log 110.92 kB · 1 download

[01:06:47.006] [Info] Root: Detected asset source named 'pm2pb' at '..\mods\Sexbound_PM2PB_2.13'
[..]
[01:08:20.212] [Error] [string "/scripts/sexbound/override/npc/pregnant.lua"]:11: attempt to call a nil value (method 'init')
[01:08:20.253] [Error] [string "/scripts/sexbound/override/npc.lua"]:34: attempt to index a nil value (field 'sb_npc')
[..]
[01:08:22.010] [Error] [string "/scripts/sexbound/override/monster/pregnant.l..."]:11: attempt to call a nil value (method 'init')
[01:08:22.012] [Error] [string "/scripts/sexbound/override/monster.lua"]:34: attempt to index a nil value (field 'sb_monster')

PM2PB (2.13) is outdated for 3.4.1 and will cause issues. Try removing the mod and attempt to use Sexbound again.

Share this post


Link to post
14 minutes ago, red3dred said:

[01:06:47.006] [Info] Root: Detected asset source named 'pm2pb' at '..\mods\Sexbound_PM2PB_2.13'
[..]
[01:08:20.212] [Error] [string "/scripts/sexbound/override/npc/pregnant.lua"]:11: attempt to call a nil value (method 'init')
[01:08:20.253] [Error] [string "/scripts/sexbound/override/npc.lua"]:34: attempt to index a nil value (field 'sb_npc')
[..]
[01:08:22.010] [Error] [string "/scripts/sexbound/override/monster/pregnant.l..."]:11: attempt to call a nil value (method 'init')
[01:08:22.012] [Error] [string "/scripts/sexbound/override/monster.lua"]:34: attempt to index a nil value (field 'sb_monster')

PM2PB (2.13) is outdated for 3.4.1 and will cause issues. Try removing the mod and attempt to use Sexbound again.

ok that fixed it thank you very much

now a different question for the new animation reverse cowgirl does it only work on some furniture or on all? since i don't have it on my animations i can pick only the normal cowgirl animation

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

×
×
  • Create New...