Jump to content

Can no longer open multiple instances of nifskope... WTF?

Recommended Posts

For some reason, I can no longer open multiple instances of Nifskope (i.e. to copy-paste branches, or look at multiple meshes at the same time, or anything, really). I can only open one instance of Nifskope and if I double click on the .exe or a .nif to open another instance... nothing happens.


Of course i tried basic stuff, like restarting, and I completely deleted my installation of Nifskope and reinstalled it. I really have absolutely no idea what's going on, as I've been using the most recent build for most of this year and this is the first time I've had this problem. There wasn't any "event" or anything like that either which should affect this, as far as I know.


Using the "New Window" function under file still works, but this is a lot more of a pain in the ass than just selecting .nifs and opening them.


I'm on Win7, if that matters.

Link to comment
21 hours ago, Andy14 said:

Either you use a New Window, or you connect the file extension "nif" with Nifskope and you can open the Nif with a double-click.


The thing is, I already did connect the extension. The file association should already be set (and indeed, nif files have the appropriate icon).


I just tried refreshing the file association, but that did nothing.


Even if I directly double-click on Nifskope.exe, it won't open a new window if I have an existing Nifskope window open.

Link to comment

Normally that is an operating system problem and is related to the actions that explorer.exe make when you double click a file with nif extension.

The solution depend of your operating system. Sometimes can be solved with ccleaner.

Un-install nifscope for remove the association and run ccleaner for really clean the association.

Then reinstall nifscope.

Link to comment
  • 1 year later...

I know this is way old, but it may help someone one day. One fix I found for this was to edit my registry in Win 7. The registry key was:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers\D:\Software\NifSkope2.0dev7_x64\NifSkope.exe

I edited the string (modify...) and changed it from "DISABLEUSERCALLBACKEXCEPTION" to "RUNASADMIN".

I don't completely know why, I only know that it was the only thing I changed before I rebooted, and it solved my problem.

Link to comment
  • 1 year later...

Say, I just noticed this belated reply, and was hoping it would work (I never did solve the issue of not being able to double-click .nif files to open a new instance of nifskope anymore - file associations was never the problem and that works correctly).


Sadly that location path doesn't work for me, and I tried running a top-level search in regedit for NifSkope2.0dev7_x64 as well as just plain NifSkope2 with no results. I assume this is because my nifskope installation file path is different from yours.


I also searched for just nifskope.exe, but that brought up a half-dozen references, none of which appeared to have the string you mentioned.


I also tried forcing the program to run as an admin, but that prompts a security warning each time, and more importantly doesn't work anyway - the second double-click on a .nif still does nothing.


I uninstalled and reinstalled nifskope in a completely fresh folder thinking that might work, but that created a nightmare! After I reinstalled, Windows refused to recognize nifskope as a valid program for the purposes for file associations! It was only by incredible luck that I tried replicating the exact file path and folder names of my previous install, which *magically* allowed Win 7 to once again recognize nifskope as a valid application, so that I could re-associate .nifs with it at all.


So as far as I can tell this is absolutely a registry issue (the weird file path problem seems to confirm it), but I really have no clue how to fix it.


Ideally Nifskope would have an installer/uninstaller, which would solve the problem of Windows recognizing it, but it doesn't.


Any ideas, anyone?



Edited by SmedleyDButler
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...