Jump to content

Recommended Posts

20 minutes ago, FayeFyee said:

Been at this issue for a few days, can't figure out where I went wrong. No matter what I try, I can't get the milk pumps to spawn in, the back of warmaidens is completely normal. Everything else with the mod seems to work, can access mcm, etc. Whenever I start the game, it gives me a pop-up saying add-ons and pumps should be installed after the main file, no matter the load order. Any help would be greatly appreciated.

You did opt to install some form of pumps from the scripts FOMOD?

Link to post
12 hours ago, Fredfish said:

You did opt to install some form of pumps from the scripts FOMOD?

Yep, when installing the script file I chose the option for fancy pumps, though I have also tried the non-bound option as well, with no luck. Does it matter the load or install order for the assets and script files?

Link to post
On 1/7/2021 at 10:07 AM, AtomicPlayboy said:

Now the issue is getting them to scale with the breasts and nipples using NiOverride and the CBBE morphs. Attaching to the "L|R Breast03" bone puts it in the right place, and using the Nipple Length morph should allow it to scale properly with the breast and nipple length. It will need to be able to scale with all of the breast morphs though.

 

You can probably use Cumshot as an example on how to do that. Cum particles from Cumshot are attached to the Genitals06 node and scale using NIO so no matter what size or shape the cock is, the cum particles will always come from the tip. Maybe Erstam can give you some ideas on how to make the particles move with the breast and nipple scales.

 

Okay, I don't know exactly how the particles are set up in MME (and I'm not going to dig into it), but if they behave strangely, it might have something to do with the weird way they work in Cumshot.

 

Cumshot objects are designed to be adjustable ingame, to make them fit on every dick shape without having to create a different nif for every SOS addon or body mesh. It's done by moving the node that they are attached to, using NetImmerse Override functions. However, you can't directly manipulate Genitals06, because in many cases parts of the penis are skinned to it, and moving the node would deform the penis.

 

Instead, the cumshot meshes are parented to a node that does not exist on the base skeleton, called "Urethra", and this is the node that is being adjusted. In order to make it work, there's a small mesh file named NodeTemplate.nif, which tells NiOverride how the new node is related to its parent, and one of the Trishapes in the particle emitter (EditorMarker) has a NiStringsExtraData named "EXTN", providing information about the helper mesh.

 

No idea if this is the reason, but you can try removing the EXTN NiStringsExtraData from the EditorMarker shape, and point the NiStringExtraData of type "Prn" (the one under the root, without an "s") to the breast bone. If you're lucky, it will scale correctly. If not, sorry, I can't help there.

Link to post
59 minutes ago, FayeFyee said:

Yep, when installing the script file I chose the option for fancy pumps, though I have also tried the non-bound option as well, with no luck. Does it matter the load or install order for the assets and script files?

Fancy pumps at least aren't all in the same location. It's a big shed so instead of being behind warmaiden's, it's in the back area between warmaidens and arcadia's shop.

 

13 hours ago, Fredfish said:

it gives me a pop-up saying add-ons and pumps should be installed after the main file

MilkModNew.esp is before all the other milk esps right?

Install assets first, then scripts

Link to post
4 hours ago, zarantha said:

Fancy pumps at least aren't all in the same location. It's a big shed so instead of being behind warmaiden's, it's in the back area between warmaidens and arcadia's shop.

 

MilkModNew.esp is before all the other milk esps right?

Install assets first, then scripts

Yeah, I understand that that the fancy has different placement, there aren't any pumps in the entirety of whiterun either way.

 

I installed assets first, but there doesn't appear to be any esps in it, the only thing I found was a MilkModNEW.seq file. But when I installed scripts, this is what I see. Do I need to move the esp into the assets mod's folder or something? Or merge the assets and scripts?

 

I attached a screenshot below of the inside of scripts mod folder, and my load order for the mod. The requirements like sexlab, skeleton, etc. are far above them, only race, armor & body mods are below so I don't think there'd be any buildings overriding the pumps.

 

Edit: tried the install process over again, installed the assets, then scripts but unchecked all the patches and things, installed scripts a second time with patches and pumps and that worked. There's a few plants inside the fancy pump but that's probably from one of the other mods I've installed lol. Thanks for the help!

snip.PNG

Link to post
5 hours ago, Erstam said:

Okay, I don't know exactly how the particles are set up in MME (and I'm not going to dig into it), but if they behave strangely, it might have something to do with the weird way they work in Cumshot.

 

Cumshot objects are designed to be adjustable ingame, to make them fit on every dick shape without having to create a different nif for every SOS addon or body mesh. It's done by moving the node that they are attached to, using NetImmerse Override functions. However, you can't directly manipulate Genitals06, because in many cases parts of the penis are skinned to it, and moving the node would deform the penis.

 

Instead, the cumshot meshes are parented to a node that does not exist on the base skeleton, called "Urethra", and this is the node that is being adjusted. In order to make it work, there's a small mesh file named NodeTemplate.nif, which tells NiOverride how the new node is related to its parent, and one of the Trishapes in the particle emitter (EditorMarker) has a NiStringsExtraData named "EXTN", providing information about the helper mesh.

 

No idea if this is the reason, but you can try removing the EXTN NiStringsExtraData from the EditorMarker shape, and point the NiStringExtraData of type "Prn" (the one under the root, without an "s") to the breast bone. If you're lucky, it will scale correctly. If not, sorry, I can't help there.

Thanks for replying!

 

The particle system MME uses for the milk leak is treated as a magic effect in game; I noticed Nipple Magic from XPMSE doesn't scale with the breast size either, since NiOverride is using CBBE scaling while Nipple Magic is (I'm assuming) using the NPC skeleton for its attachment point. Do you think your suggestion would help?

 

Edit: the magic effect applies an art object (ARTO). I don't know if that has any bearing on how it works though. I'm trying to figure out how exactly the Cumshot particle system attaches and am going to try to replicate it for the milk leak effect using a dummy "nipple" node.

Link to post

Im relativly new to modding but ive done my best to do my research first. I still dont know why this mod under plugins tells me that those files are for a diffrent game. (I have Skyrim special edition). This mod is for SE right? So i dont understand why it says that. (The assets file works fine, just the scripts one gets the error) 

  • 63d85f14bb18d2613c442175108c36bc.png
Link to post
20 hours ago, BossMerkel said:

Im relativly new to modding but ive done my best to do my research first. I still dont know why this mod under plugins tells me that those files are for a diffrent game. (I have Skyrim special edition). This mod is for SE right? So i dont understand why it says that. (The assets file works fine, just the scripts one gets the error) 

  • 63d85f14bb18d2613c442175108c36bc.png

Because the mod is still in form 43 and not 44.

Link to post

Hi there, I seem to be having an issue I've not found record of anywhere else.

The mod was working fine the other day; but after starting a new save file, there is no longer any Milk Production. Everything else still works - Lactacid increases, the breast and belly node is altered, the milk pumps work fine, I can still make new Milk Maids, ect. But there is no longer an hourly update in Milk Production, effectively rendering the mod useless. Has anyone else encountered this issue?

I haven't added any new mods since the previous save file that could contend with it. I've attempted re-running FNIS, altering my load order, reinstalling the whole mod, starting new save files, I even checked to make sure this was the only hourly event having issues; which it is.


Any help would be greatly appreciated, thank you.

Link to post

Mildly relevant to my last post, I noticed a bug--when the "breasts" debuff gets to about 10 or 11 it then wraps back around to 4 and starts from the bottom. I'm not an expert but inexplicable titty shrinkage doesn't seem like it's supposed to happen...help?

Link to post
4 hours ago, inkyvonstump said:

Mildly relevant to my last post, I noticed a bug--when the "breasts" debuff gets to about 10 or 11 it then wraps back around to 4 and starts from the bottom. I'm not an expert but inexplicable titty shrinkage doesn't seem like it's supposed to happen...help?

its based on breast node, depending on you mods it after it reaches max value it starts from 1 again

Link to post
On 1/2/2021 at 5:08 PM, km4387 said:

I'm very confused by all this - I have 3BBB, SLIF, the Tullius json files, fertility 3.0. Milk mod works, but I don't generally see any morphs.  When I think I see it, it turns out my maid is pregnant from fertility. I believe these mods should work together and increase breast size based on both.  What do I need to make these mods work together?

If anyone cares - or maybe I can help someone - I finally figured it out by enabling debug mode in Milk Mod. My milkmaids were all set to have "Increase per milk" and "Increase per level" set to -1 by default - which disables morphs.  When I set both of those to 1.0, things finally started working as I thought they should. Haven't tested with Pregnancy yet.

 

I do feel that should be a global setting in the settings menu - I might have seen it sooner. Plus it has to be done for each maid, rather than just one setting that applies to each.  Maybe there's a good reason for it, I dunno and my "attempt to be a coder" days are over. Just my two cents.

 

Regardless, thanks for the mod (and your other mods) Ed. Nice work.

Link to post
13 hours ago, km4387 said:

If anyone cares - or maybe I can help someone - I finally figured it out by enabling debug mode in Milk Mod. My milkmaids were all set to have "Increase per milk" and "Increase per level" set to -1 by default - which disables morphs.  When I set both of those to 1.0, things finally started working as I thought they should. Haven't tested with Pregnancy yet.

 

I do feel that should be a global setting in the settings menu - I might have seen it sooner. Plus it has to be done for each maid, rather than just one setting that applies to each.  Maybe there's a good reason for it, I dunno and my "attempt to be a coder" days are over. Just my two cents.

 

Regardless, thanks for the mod (and your other mods) Ed. Nice work.

that is because -1 is a value that forces script to use global settings

Link to post
11 hours ago, km4387 said:

If anyone cares - or maybe I can help someone - I finally figured it out by enabling debug mode in Milk Mod. My milkmaids were all set to have "Increase per milk" and "Increase per level" set to -1 by default - which disables morphs.  When I set both of those to 1.0, things finally started working as I thought they should. Haven't tested with Pregnancy yet.

 

I do feel that should be a global setting in the settings menu - I might have seen it sooner. Plus it has to be done for each maid, rather than just one setting that applies to each.  Maybe there's a good reason for it, I dunno and my "attempt to be a coder" days are over. Just my two cents.

 

Regardless, thanks for the mod (and your other mods) Ed. Nice work.

This was the solution to my problem, thank you! I've spent over a week trying to figure this out!

Link to post
On 1/21/2021 at 2:36 PM, pyroboy150 said:

Okay. I can't find what the difference is between "Bound milkpumps" and "unbound milkpumps"... what does this mean?

The unbound are the titty pumps you find in most all places, like cities, towns.  The bound are the fancy pumps in special caves.  Think that’s right??

Link to post

Is there a way to temporarily deactivate the Anti-Heavy-Armor thing? The function witch unequips your heavy armor breastpeace if your honkers are too large. It sometimes bothers me because i just want to try on some new armor i newly downloaded without getting milked first. 

If there is no such option could you @Ed86 implement it?

Link to post
21 hours ago, Crym said:

Is there a way to temporarily deactivate the Anti-Heavy-Armor thing? The function witch unequips your heavy armor breastpeace if your honkers are too large. It sometimes bothers me because i just want to try on some new armor i newly downloaded without getting milked first. 

If there is no such option could you @Ed86 implement it?

Its available in the debug menu. Enable debug mode, return to the menu and disable armor stripping.

Link to post
19 hours ago, lurkmoar89 said:

Its available in the debug menu. Enable debug mode, return to the menu and disable armor stripping.

Ohh i didnt knew this is possible, thanks alot.

Link to post

Few problems I came across neither P C or NPC can use any milking station even with the patch. When you try to enter it you can't control your character as if something is about to happen but then nothing then you go back.

The futa milking harness is simply invisible along with making your body invisible

The normal milking harness while you can see it and it attaches fine it's completely purple, yes I have ZAZ animation (8) pack as well as all the files required 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...