Jump to content

MaryJane

Members
  • Posts

    577
  • Joined

Profile Information

  • Pass that Dutch
  • Gender
    She/Her
  • Location
    Europe

Recent Profile Visitors

17,777 profile views
  1. No, of course not. That would require coding and I'm not a modder. These are just animations you can play in the game as all other animations Would love to make it a real sleep scene, but I don't have the knowledge how to do that. I might eventually look into replacing some of oniki's animations with these so that they coun't as real sleep sex.
  2. Whatever you want it to be for your gameplay If she is really asleep then it can't be consensual (unless they are partners and agreed to it or something!)
  3. Honestly, this is really not my forte so I'm not sure. I do know that when you clone an object, it renames internally (or else it conflicts with the original). Maybe that has something to do with it? I have not tested yet with both files in game, will do that too
  4. I don't think that has anything to do with it. I just tested it, the cuffs work fine in my game when I have the original file in my game. When I put the ones you made in and only those, then the cuffs don't seem to work for me either. Which of the cuffs do you have in game?
  5. Huh, that's very strange, that they suddenly don't work with that build!
  6. It's indeed a issue with the build. I don't remember in which build Oniki implemented the use of the handcuffs. I asked her a while ago to add code to support them and she did, but I relly don't remember which build and onwards they are supported. If you use the latest build you should be save
  7. No problem, I hope you figure it out. It is super frustrating to have something that goes wrong and you don't know what went wrong exactly. Trust me, I have been there 100 times myself, and I was also unfortunate that there weren't any other animators active at that moment. It sucked! Try to fiddle around a bit, see if you can find what went wrong. If you really can't find it, you may send me your files and I will take a look at it. But try it yourself first, you will learn the most from that 🙂
  8. Your dopesheet looks fine. The orange line between keyframes means that you didn't change anything between the keyframes, so that they're duplicates of each other (if I remember correctly! I'm a bit rusty with animations atm). Unless that wasn't your intention, there is nothing wrong with that. If your animation is good in blender but doesn't work in game, the possibilities could be: 1. something went wrong with baking 2. you forgot to bake/didn't bake correctly 3. you messed with parenting of some bones (I remember when I fucked up the parenting of the ROOT bone, the animation was fine in blender but went under ground in game) 4. you didn't import your animation in to your package file (sounds stupid, but it really happened to me once! If there is no animation to read that you specified in the XML, your sim will just stand there) or you made a mistake in the XML so the game doesn't 'know' which animation to play.
  9. I did a quick update on the text about baking and added a link to the updated cliptool that I found. Clydie informed me that baking also worked on newer versions of Blender, but that it works a little different - you have to uncheck everything for some strange reason. But if it works, it works! I have not tested it yet myself because I'm not animating atm. The update in text was real quick and dirty. I will update more thoroughly once I tested everything and know what to do and what not to do.
  10. Well, then it isn't the blender version! The child of constraint shouldn't have anything to do with it - I often animate without it too and never have problems with baking. I can't be sure why your animation isn't doing anything after baking. If you have the keyframes in the dopesheet and checked and unchecked the right things in the baking process, it should be the same animation as before that. Check if you 1. have 'pose' clicked when baking 2. if the frame step is 1, 3. if you left 'clear parenting' and 'only selected' unchecked and 4. if you did check 'clear constraints',
  11. There was another user that had problems with baking, and it appeared that they used an incompatible blender version. So, which blender version are you on?
  12. What did you do exactly? Is this your own animation or did you alter one from another animator? If you did the last, the IK on the legs probably got lost when moving the rigs.
  13. That is very weird and should not happen (unless you use sliders, but you said you didn't) It doesn't look like this in Blender?
  14. I'm not sure what you did and what happened. If it worked one time it should also work the other time if it's the same animation, makes no sense otherwise! Or maybe you did two different things without realizing? And we all start clueless, that doesn't matter! If you really want it you eventually will get better and start to understand more. Thing is, it is really complicated so you will have to work for it. Even a 'stiff as a board' animation isn't necessarily easy to make, you will still need to know how to work blender a bit. Patience is the key with animating, and most of all, not giving up! Edit: sorry, only now read your other message about it being two different animations. Yes, this can indeed happen. I converted some L666 animations for bed height. They were all in the same sequence, but not all worked, even with location constraint! VERY weird things happened. I remember that Lucas sometimes also altered animations by moving only the ROOT bone (often this bone is hidden). But I'm always cautious doing that, I have very bad experiences with playing around with the ROOT bone. But if it worked for him, maybe that is something you could try. Worst thing that can happen is that it doesn't work (in my case, I made a whole animation from scratch, did wrong parenting with the ROOT bone and could start over, lol)
×
×
  • Create New...