Jump to content

Welcome to LoversLab
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

CBBE / UUNP / BodySlide and Outfit Studio

CBBE UUNP BodySlide Outfit Studio Unified UNP Body ousnius Caliente Outfit

  • Please log in to reply
208 replies to this topic

#41
RedMonika

RedMonika

    Senior Member

  • Members
  • PipPipPipPip
  • 497 posts

 

 

 I got the same crashing issue V 3.8, after about 3 Ctrl-z's, Bodyslide will crash. Thought it was just me.

 

I fixed undo/redo in v3.7.2 once and haven't been getting any crashes myself since, no matter what or how often I undo/redo.

 

Does it happen to all meshes for you?

What brushes are you using when it crashes?

What tab (meshes, bones, partitions) do you have activated?

Did you brush on multiple shapes at the same time?

 

 

  Can't remember the specifics but usually i'm in the Meshes tab, using inflate/deflate and smooth the only brushes i use. Top of my head my last crash was Ctrl-Z on the CBBE Hdt body, because i accidentally got the brush to select the body instead of the mesh i was working on, so i tried to back step using Ctrl-z and it crashed, think was only 2 presses of Ctlr-Z that it crashed.

  Usually i work on one mesh at a time. Don't know if that helps as i don't really recall the specifics of the crash.

 

Will try to have a more detailed account next time, sorry.

 

 

That's what I do too.

@Vortec do you have multiple outfit studio windows open and or do you leave it up? I tend to leave my computer on and just let it go to sleep. Outfit Studio could be minimized but it's up most of the time as I'm doing new mashups for my game.

 

I just closed everything and can't reproduce it now. Before closing it I brought up a .nif and got it to crash without editing anything.


  • 0

AdBot

AdBot
  • Advert

#42
Vortec

Vortec

    Senior Member

  • Members
  • PipPipPipPip
  • 350 posts

 No i usually shut down Bodyslide after I'm done using it. Rare that i have Multiple Bodyslide windows open, only do that because i can't remember which Nif of the 0 or 1 i'm saving too, and Bodyslide doesn't display which Nif i'm working on.

 

 I just crashed again, and a bug that sometimes happens. I was editing a mesh that i had selected, but the inflate function was confused and actually did the Deflate function..after i notice the Inflate function behaving like the Deflate i Ctrl-Z once and Bodyslide crashed.

 I recall the Inflate brush acting confused before, instead of Inflating it Deflated. And yes the Inflate Brush was Highlighted, i switched around to the other brushes which worked as advertized, but the Inflate behaved as the Deflate.


  • 0

#43
ousnius

ousnius

    was cell

  • Contributor
  • PipPipPipPipPip
  • 2,681 posts

No i usually shut down Bodyslide after I'm done using it. Rare that i have Multiple Bodyslide windows open, only do that because i can't remember which Nif of the 0 or 1 i'm saving too, and Bodyslide doesn't display which Nif i'm working on.

I just crashed again, and a bug that sometimes happens. I was editing a mesh that i had selected, but the inflate function was confused and actually did the Deflate function..after i notice the Inflate function behaving like the Deflate i Ctrl-Z once and Bodyslide crashed.
I recall the Inflate brush acting confused before, instead of Inflating it Deflated. And yes the Inflate Brush was Highlighted, i switched around to the other brushes which worked as advertized, but the Inflate behaved as the Deflate.


Did you hold down the ALT key while the inflate acted as a deflate? Because that's what ALT does.
  • 0

#44
Vortec

Vortec

    Senior Member

  • Members
  • PipPipPipPip
  • 350 posts

Did you hold down the ALT key while the inflate acted as a deflate? Because that's what ALT does.

 

Umm well no because i never knew that. To me Inflate was suppose ...Inflate,  didn't know why and didn't know about holding down ALT key if it did that. May i ask why it's behaving like that in the first place?.

 

 Still it caused a crash Ctrl-Z. 

 

Would you mind if i posted next time it crashes?. Still remembering it crashing from accidentally inflating the CBBE base mesh instead of the armor mesh i was working on. I have 16 Ram, have no problems with Ctrl-Z in Blender (20+ ).

 

 Is there a Keyboard cheat sheet for BodySlide somewhere, as the ALT is news to me and probably to lot of others too.

 

  ...runs off to play with the ALT key in Bodyslide


  • 0

#45
ousnius

ousnius

    was cell

  • Contributor
  • PipPipPipPipPip
  • 2,681 posts

Did you hold down the ALT key while the inflate acted as a deflate? Because that's what ALT does.

 

Umm well no because i never knew that. To me Inflate was suppose ...Inflate,  didn't know why and didn't know about holding down ALT key if it did that. May i ask why it's behaving like that in the first place?.

 

 Still it caused a crash Ctrl-Z. 

 

Would you mind if i posted next time it crashes?. Still remembering it crashing from accidentally inflating the CBBE base mesh instead of the armor mesh i was working on. I have 16 Ram, have no problems with Ctrl-Z in Blender (20+ ).

 

 Is there a Keyboard cheat sheet for BodySlide somewhere, as the ALT is news to me and probably to lot of others too.

 

  ...runs off to play with the ALT key in Bodyslide

 

https://github.com/o...board-Shortcuts

The ALT thing is intentional, the crash isn't (of course). I'll have to take a look at it closer, but not right now.


  • 1

#46
ousnius

ousnius

    was cell

  • Contributor
  • PipPipPipPipPip
  • 2,681 posts
- General: Fixed texture path correction for some very rare cases.
- General: Improved quality of normal smoothing on meshes. Not customizable just yet.
- BodySlide: Made group selection in the group manager more clear (disabling panels).
- Outfit Studio: Improved SK -> SSE NIF optimization stability.
- Outfit Studio: Duplicating a shape is faster now when there are many loaded.

  • 3

#47
RedMonika

RedMonika

    Senior Member

  • Members
  • PipPipPipPip
  • 497 posts

 

- General: Fixed texture path correction for some very rare cases.
- General: Improved quality of normal smoothing on meshes. Not customizable just yet.
- BodySlide: Made group selection in the group manager more clear (disabling panels).
- Outfit Studio: Improved SK -> SSE NIF optimization stability.
- Outfit Studio: Duplicating a shape is faster now when there are many loaded.

 

 

Thank you for your work!


  • 0

#48
Slorm

Slorm

    Mega Poster

  • Members
  • PipPipPipPipPip
  • 2,707 posts

 

- General: Fixed texture path correction for some very rare cases.
- General: Improved quality of normal smoothing on meshes. Not customizable just yet.
- BodySlide: Made group selection in the group manager more clear (disabling panels).
- Outfit Studio: Improved SK -> SSE NIF optimization stability.
- Outfit Studio: Duplicating a shape is faster now when there are many loaded.

 

 

Many thanks, that sorts out the discolouration problem :)
 


  • 0

#49
usernamewow

usernamewow

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Hi i think my computer has issues with the new renderer from 3.8, because in the preview and the outfit studio the body appears blank, even missing the "no image" texture, is there anywhere i can find an older version so i can get around it? this must have something to do with my old computer so i don't see any other way around it.


  • 0

#50
Enelysion

Enelysion

    Member

  • Members
  • PipPip
  • 19 posts

Weird question, but If an outfit nif has the textures properly directed to the appropriate files but the textures don't show up when the outfit is loaded into outfit studio, what could be the problem? 

 

Any help would be appreciated. Thanks.


  • 0

#51
RedMonika

RedMonika

    Senior Member

  • Members
  • PipPipPipPip
  • 497 posts

Hi i think my computer has issues with the new renderer from 3.8, because in the preview and the outfit studio the body appears blank, even missing the "no image" texture, is there anywhere i can find an older version so i can get around it? this must have something to do with my old computer so i don't see any other way around it.

 

You're actually on an older version. So, are you referring to BaseShape (Typically what the body is named). Sometimes an armor mesh won't have a base body with it. Is this with everything or a specific armor?


Weird question, but If an outfit nif has the textures properly directed to the appropriate files but the textures don't show up when the outfit is loaded into outfit studio, would could be the problem? 

 

Any help would be appreciated. Thanks.

 

So, under the properties for an armor piece the texture path is correct or does it show up in game? You can manually set the textures through outfit studio. What armor are you working with?


  • 0

#52
Enelysion

Enelysion

    Member

  • Members
  • PipPip
  • 19 posts

 

Weird question, but If an outfit nif has the textures properly directed to the appropriate files but the textures don't show up when the outfit is loaded into outfit studio, would could be the problem? 

 

Any help would be appreciated. Thanks.

 

So, under the properties for an armor piece the texture path is correct or does it show up in game? You can manually set the textures through outfit studio. What armor are you working with?

 

 

Yeah, the texture paths were correct. I checked time and time again and whenever I loaded the outfit in-game, my char's entire body was transparent (with only the head, hands and feet showing). 

 

It seems to be working fine now though. I have no idea what I did, but the textures are loading. Thanks anyway for responding.

 

And I'm working with ISOP Maid if you're still curious.


  • 1

#53
RedMonika

RedMonika

    Senior Member

  • Members
  • PipPipPipPip
  • 497 posts

 

 

Weird question, but If an outfit nif has the textures properly directed to the appropriate files but the textures don't show up when the outfit is loaded into outfit studio, would could be the problem? 

 

Any help would be appreciated. Thanks.

 

So, under the properties for an armor piece the texture path is correct or does it show up in game? You can manually set the textures through outfit studio. What armor are you working with?

 

 

Yeah, the texture paths were correct. I checked time and time again and whenever I loaded the outfit in-game, my char's entire body was transparent (with only the head, hands and feet showing). 

 

It seems to be working fine now though. I have no idea what I did, but the textures are loading. Thanks anyway for responding.

 

And I'm working with ISOP Maid if you're still curious.

 

 

That's good it's working now


  • 0

#54
usernamewow

usernamewow

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

 

Hi i think my computer has issues with the new renderer from 3.8, because in the preview and the outfit studio the body appears blank, even missing the "no image" texture, is there anywhere i can find an older version so i can get around it? this must have something to do with my old computer so i don't see any other way around it.

 

You're actually on an older version. So, are you referring to BaseShape (Typically what the body is named). Sometimes an armor mesh won't have a base body with it. Is this with everything or a specific armor?

 

Actually I downloaded the latest one, I mentioned 3.8 because that's when the renderer change happened. Up until now i was using a version previous to 3.8 without any issue, and the issue happened after i got the latest version. I decided to clean up a 4 year old skyrim folder by deleting everything and i don't have an older version of bodyslide.

What I'm really hoping for is that somebody could just upload a pre 3.8 version, (3.7.5 preferrably) because they don't go back that far in the older version list on the nexus.


  • 0

#55
Otsir

Otsir

    Member

  • Members
  • PipPip
  • 22 posts

I have a custom body that romeozero made for me and I'm trying to figure out how to convert armors to it but I'm not having any luck with it. It wasn't made with bodyslide and its skinned and rig. romeozero was helping but he now has RL things to handle. If I could get any help with I would really appreciate it. I have some 3ds max screens and the body nifs attached.                

 

this is Unified UNP Special with 7b preset,with much more poligons.So it shouldn't be any problem to convert outfit.

Attached Files


  • 0

#56
Enelysion

Enelysion

    Member

  • Members
  • PipPip
  • 19 posts

Hey. Wondering if anyone can shed some light on why this is happening? 

 

Spoiler

 

It's the Bridal Set by ANK. 

 

That part of the outfit has HDT physics. Trying to work out why it's being stretched like that?


  • 0

#57
SassaAria

SassaAria

    Member

  • Members
  • PipPipPip
  • 186 posts

Feature Request:   Is smoothing (blending, smudging, averaging) for weight paint a feature that might be added sometime? 

The mesh smoothing has been handy several times already.

For some outfits that aren't tight to the body, or using non-deafult bones, or different effects, being able to weight paint in Outfit Studio is just really great to have.  Having a blending brush would make that go many times faster and easier.


  • 0

#58
SassaAria

SassaAria

    Member

  • Members
  • PipPipPip
  • 186 posts

Hey. Wondering if anyone can shed some light on why this is happening?

It's the Bridal Set by ANK. 

 

That part of the outfit has HDT physics. Trying to work out why it's being stretched like that?

 

Sorry, don't know the outfit and it's mesh.

Do you think it's the HDT doing that?

If not, often funny streching is weight-paint related. 

You could check all the bones in OS in case there's some off-weight paints.


  • 0

#59
ousnius

ousnius

    was cell

  • Contributor
  • PipPipPipPipPip
  • 2,681 posts

Feature Request: Is smoothing (blending, smudging, averaging) for weight paint a feature that might be added sometime?
The mesh smoothing has been handy several times already.
For some outfits that aren't tight to the body, or using non-deafult bones, or different effects, being able to weight paint in Outfit Studio is just really great to have. Having a blending brush would make that go many times faster and easier.


Already exists, check the wiki on brushes and/or shortcuts.
  • 0

#60
SassaAria

SassaAria

    Member

  • Members
  • PipPipPip
  • 186 posts

 


Already exists, check the wiki on brushes and/or shortcuts.

 

 

That's great news :D

+"Shift" key

 

Tooltip only referred to "alt".  And mesh has own smooth button. 

Based on that thought it didn't exist.  Tools were so easy to use, never had reason to read over wiki for that.

Thank you.

 

Update: Outfit Studio Crash

Also, update on that Sweetpea coat outfit that was crashing Outfit Studio.

Still happened with newer versions.

 

Changed tactics.  Reimported mesh as objs into OS.

Crashed again when linking textures with fatal exception.

(Did you load textures as well when you tested that mesh? or let it default to noimage?)

 

Checked the dds in photoshop and image format was indexed 8byte.

Changed it to RGB and saved as u8.8.8.8 and now works fine in OS.

 

Interesting that game accepts that format.

 

 

 


  • 0



Also tagged with one or more of these keywords: CBBE, UUNP, BodySlide, Outfit Studio, Unified UNP, Body, ousnius, Caliente, Outfit